The shift from "regexp" to "rx" partway through the API feels clumsy. To
me, it signals a difference in meaning where AFAICT there isn't one.
IMHO, the `rx-match` record type should rather be called "regexp-match",
or simply "match". This would align the rx-* procedures with the rest of
the API in clarity of names. (I recognize the collision on
`regexp-match?`, but that procedure could instead be called
"regexp-occurs?" or somesuch, which I'd argue is more descriptive
anyway.)
I like irregex's example here, with its nice, explicit "irregex-match-"
prefixes.
(Sorry for what some might consider bikeshedding, but I do think good
names matter.)
Evan
P.S. Unrelatedly, I agree re: `<-` replacing `=>`.