These changes have been published as draft #4:

---------- Forwarded message ----------
From: Bradley Lucier <xxxxxx@github.com>
Date: Thu, Sep 3, 2015 at 8:58 AM
Subject: [srfi-122] Rename array-manipulators => storage-class, add storage classes for complex numbers with f32 and f64 real and imaginary parts. (#3)
To: scheme-requests-for-implementation/srfi-122 <srfi-122@noreply.github.com>

Rename "array-manipulators" to "storage-class".
Add storage classes for 64-bit and 128-bit complex rectnums. (Man, what an unfortunate name.)
Add a few more tests to increase coverage.
Update Draft date
 
Commit Summary
  • Rename "array-manipulators" to "storage-class".
  • Set date of Draft #4.
  • Add date of Draft #4.
File Changes
  • M generic-arrays.scm (214)
  • M srfi-122.html (230)
  • M srfi-122.scm (287)
  • M test-arrays.scm (152)