Re: dilation type seems unnecessary Bradley Lucier 29 Jul 2015 20:34 UTC

> On Jul 29, 2015, at 12:25 PM, Per Bothner <> wrote:
> The dilation type adds an extra concept (and name) without any apparant
> extra functionality.  Instead of:
>  (Interval-dilate interval (Dilation lower-bounds upper-bounds))
> why not just:
>  (Interval-dilate interval lower-bounds upper-bounds)

Perhaps.  I often find in a given application that a specific dilation is constructed once and then applied many times.  I put a lot of error checking into the code, and some of that can be done once at dilation construction time and then only some of the checking need be done when the dilation is applied.

But I agree, the concept of dilations does not add much.

> Would Internal-adjust be a better name than Internal-dilate?

<anything>-adjust does not specify in which way <anything> is adjusted.  I’m not wedded to the name interval-dilate, but I’d like any alternative to be specific.