Re: Terminology Bradley Lucier 29 Jul 2015 22:08 UTC

> On Jul 29, 2015, at 5:35 PM, John Cowan <xxxxxx@mercury.ccil.org> wrote:
>
> I think the name fixed-array is confusing and should be replaced with
> rectangular-array.

I’m not wedded to fixed-array, but all arrays are rectangular in some sense.  I thought “array-with-backing-store” was too long ;-).

> I would prefer a singular noun instead of array-manipulators; I suggest
> storage-class, which allows it to be used with objects other than arrays.

I like the idea of using a name that is not tied to arrays.  I’m not sure that storage-class is it.  Maybe it is.

> Note that, like comparator, this is like a Haskell type class.

I’m sorry, but I don’t understand this statement, and I don’t know Haskell.

> I don't like the name "dilation" either but don't have a suggestion right now.

Ah, perhaps “dilations” will be removed from this SRFI, then we won’t have to worry about the name.

Brad