Re: dilation type seems unnecessary Bradley Lucier 31 Jul 2015 20:39 UTC

On 07/29/2015 04:34 PM, Bradley Lucier wrote:
>> On Jul 29, 2015, at 12:25 PM, Per Bothner <> wrote:
>> The dilation type adds an extra concept (and name) without any apparant
>> extra functionality.  Instead of:
>>  (Interval-dilate interval (Dilation lower-bounds upper-bounds))
>> why not just:
>>  (Interval-dilate interval lower-bounds upper-bounds)
> Perhaps.  I often find in a given application that a specific dilation is constructed once and then applied many times.  I put a lot of error checking into the code, and some of that can be done once at dilation construction time and then only some of the checking need be done when the dilation is applied.
> But I agree, the concept of dilations does not add much.

I've removed dilations and changed the calling convention for
interval-dilate.  This change has been pushed to the main repository.