Bradley Lucier scripsit:
> > I would prefer a singular noun instead of array-manipulators;
> > I suggest storage-class, which allows it to be used with objects
> > other than arrays.
>
> Please explain in which way this set of functions and a value is a
> "class" of something.
It represents a type of storage that is specified using the methods
by which it is accessed and manipulated. Similarly, a SRFI 114
comparator represents a type of object through the methods of
comparing it either directly or through a hash function. Note that
in Gauche, which layers standard Scheme types on top of a classical
single-inheritance OO system, make-array accepts a type object.
See <http://practical-scheme.net/gauche/man/gauche-refe_77.html>.
> How about storage-manipulators?
That is better, but from the user perspective this is a unitary object,
not a collection, even though it has a collection of procedures inside it.
That's why I think it should have a name in the singular. We do not
refer to a vector as an "elements".
--
John Cowan http://www.ccil.org/~cowan xxxxxx@ccil.org
How comes city and country to be filled with drones and rogues, our highways
with hackers, and all places with sloth and wickedness?
--W. Blith, Eng. Improver Improved, 1652