internals - some thoughts Per Bothner 03 Sep 2016 07:13 UTC

Why use the term "domain" in some places while you use "interval" in others?

I still think "shape" might bet preferable.  For example
"array-shape" instead of "array-domian".

Drop interval-lower-bounds->list and interval-upper-bounds->list.

You can use vector-map many places where you use XXX->list.  E.g.
(map >= (vector->list lower-bounds1) (vector->list lower-bounds2))
should be
(vector-map >= lower-bounds1 lower-bounds2)

Unless you require intervals to be a distinct type (which I would
not recommend) then I think the interval? predicate is useless.

I would prefer keeping the traditional term "rank".  Thus
interval-dimension should be interval-rank (or shape-rank).
array-dimension should be array-rank.
An array doesn't have "a dimension", it has "a number of
dimensions".  But that is clumsy.  Hence "rank".
	--Per Bothner