Re: Last call for comments on SRFI 122: Nonempty Intervals and Generalized Arrays Bradley Lucier 05 Dec 2016 18:35 UTC

On 11/30/2016 09:13 PM, John Cowan wrote:
> 1) I think that interval-divide is a better name than interval-curry.
> It reflects the analogous use of "divide" in Codd's' relational algebra.

About naming what is now called interval-curry:

1.  One could use a term from colloquial English---divide or split, say.
  (I don't like "chop" because in my use of colloquial English one often
discards the part that's been chopped off.)

2.  One could use a suggestive term from a related field.

I chose "interval-curry" from currying in programming languages.

John suggests "interval-divide" from the division operator in Codd's
relational algebra.

After thinking about it, I'm going to use "interval-projections".  The
result of the operation is the same as the projection operator in
relational algebra; it's also projections in set theory.  It returns two
projections of the interval, which are chosen by the second parameter.

Brad