unfortunate that this conflicts with Gauche, but shouldn't one useObviously the better (best?) name for this is hash-table-pop!. It's
(pop! (hash-table-ref ht k) x)
for popping from a generic place, obviating the need for any *-pop!
operations specialized for different data structures?
OK, that's less efficient. I would question how often that difference
in efficiency is relevant though. If we absolutely want the efficient
push/pop then maybe we should name them hash-table-update/pop! and such.
Or let users define that when they want it and leave it out of the spec.