Email list hosting service & mailing list manager

SRFI 130 - "span" prefix Per Bothner (04 Dec 2015 03:34 UTC)
Re: SRFI 130 - "span" prefix John Cowan (04 Dec 2015 15:54 UTC)
Re: SRFI 130 - "span" prefix Per Bothner (04 Dec 2015 16:10 UTC)
Re: SRFI 130 - "span" prefix taylanbayirli@xxxxxx (04 Dec 2015 16:49 UTC)
Re: SRFI 130 - "span" prefix John Cowan (05 Dec 2015 07:05 UTC)
Re: SRFI 130 - "span" prefix John Cowan (06 Dec 2015 06:44 UTC)
Re: SRFI 130 - "span" prefix Shiro Kawai (04 Dec 2015 18:49 UTC)
Re: SRFI 130 - "span" prefix John Cowan (05 Dec 2015 07:06 UTC)
Re: SRFI 130 - "span" prefix Shiro Kawai (05 Dec 2015 07:21 UTC)
Re: SRFI 130 - "span" prefix John Cowan (05 Dec 2015 16:51 UTC)
Re: SRFI 130 - "span" prefix Per Bothner (05 Dec 2015 17:20 UTC)
Re: SRFI 130 - "span" prefix Shiro Kawai (05 Dec 2015 17:39 UTC)
Re: SRFI 130 - "span" prefix John Cowan (05 Dec 2015 20:00 UTC)
Re: SRFI 130 - "span" prefix Alex Shinn (04 Dec 2015 16:52 UTC)
Re: SRFI 130 - "span" prefix Shiro Kawai (04 Dec 2015 20:27 UTC)
Re: SRFI 130 - "span" prefix John Cowan (07 Dec 2015 00:02 UTC)
Re: SRFI 130 - "span" prefix Shiro Kawai (07 Dec 2015 07:57 UTC)
Re: SRFI 130 - "span" prefix John Cowan (07 Dec 2015 13:09 UTC)
Re: SRFI 130 - "span" prefix John Cowan (06 Dec 2015 02:32 UTC)
Re: SRFI 130 - "span" prefix Alex Shinn (07 Dec 2015 19:26 UTC)
Re: SRFI 130 - "span" prefix John Cowan (07 Dec 2015 19:48 UTC)
Re: SRFI 130 - "span" prefix Shiro Kawai (07 Dec 2015 20:08 UTC)
Re: SRFI 130 - "span" prefix John Cowan (07 Dec 2015 20:25 UTC)
Re: SRFI 130 - "span" prefix Shiro Kawai (07 Dec 2015 20:44 UTC)

SRFI 130 - "span" prefix Per Bothner 04 Dec 2015 03:33 UTC

I really dislike the habit of having separate names for different functions
that abstractly do the same thing - I think it is very user-unfriendly.
If a "span" is a sequence of characters, call it what it is: a string.

For example the "span cursor" API.  These appears to be the same as the Kawa
and Chibi 'string-cursor-XXX" functions renamed to "span-cursor-XXX'.

http://www.gnu.org/software/kawa/Strings.html#String-Cursor-API

I am not going to add a whole slew of duplicated function names.
That is just a non-starter.  In general, the span-XXX functions need be
renamed to string-XXX.  Otherwise, I'm just going to ignore this as
yet another bloated duplication.

One can fix this this by having:
(1) a portable implementation that matches more-or-less the current proposal
(2) a portable library that wraps (1) *and* native strings.

For example:
   (import (rename (scheme base) (string? core-string?) ...

   (define (string? x) (or (core-string? x) (span? x))
   (define (->span x) (if (core-string? x) (make-whole-span? x) x))
   (define (string take-right s n)
      (span-take-right (->span s) n))
   etc

The point is that the span-XXX functions in (1) are private to the implementation;
nobody should be writing programs with them.

Of course an implementation may provide native support for substrings/spans.
--
	--Per Bothner
xxxxxx@bothner.com   http://per.bothner.com/