@vector-unfold
says "On the first call to f, the state's value is zero", should be "the state's value is seed."
@vector-cumulate
it can be a bit more verbose. How about something like this:
Like @vector-fold, but returns an @vector, which has the same length of @vec, and
the 0-th element is the first result of (f nil), the next element is the result of (f (f nil)) and so on.
@vector-take-while
@vector-take-while-right
@vector-drop-while
@vector-drop-while-right
missing close paren
for take-* : shouldn't it be "the longest"?
@vector-index
@vector-index-right
@vector-skip
@vector-skip-right
It's obvious, but just for completeness: Add "Returns #f if there's no such element"
@vector-any
Should return the first true result of pred?, not the element.
@vector-every
Should return the last true result of pred? if all elements satisfy it, not the element.
@vector-filter
@vector-remove
missing closing paren
@vector->vector
vector->@vector
Don't they support optional start/end arguments?
The library names:
The distinction of (srfi 160 base) and other srfi 160 library is explained under "implementation". So it's not clear if it's just the reference implementation's strategy, or the library names are a part of the specification that all conforming implementations should follow. If it's indeed the case, maybe we can have "Library names" section after "Notation".