A couple of things that I noted while rereading the current draft:
(1) make-bitvector's fill argument is a bit (i.e. 0, 1, or a boolean),
as are the arguments of `bitvector'. I suggest the names "bit"/"bits"
instead of "fill"/"values", respectively.
(2) It seems that bitvector-reverse! and bitvector-field-reverse! do
the same thing, except that the start and end arguments of
-field-reverse! are mandatory. Are both necessary?
(3) Just as with bitvector-unfold, we should unify the unfold-right/{int,
bool} procedures and provide a single right unfold. This has already
been done in the sample implementation.
(4) bitvector->vector/{int, bool} and vector->bitvector should have
optional start and end arguments.
(5) The meaning of the optional len argument of bitvector->integer
should be documented.
(6) I believe John decided that the bitvector-generator functions
should be renamed to make-bitvector/{int, bool}-generator. I've
made this change in the implementation, but not it seems not to
have made it into the document.
Regards,
--
Wolfgang Corcoran-Mathe <xxxxxx@sigwinch.xyz>
"The most important computer is the one that rages in our skulls
and ever seeks that satisfactory external emulator." --Alan J. Perlis