Re: SRFI 43 vs. R7RS-small John Cowan 28 Oct 2015 16:13 UTC

Shiro Kawai scripsit:

> If we have a chance to revise it, I'm for the option #2---make a new srfi
> that supersedes srfi-43
> with minimal renaming.  New code will be benefited by clean and consistent
> naming, and
> it'll be trivial to support legacy code that uses srfi-43 explicitly.

The trouble is that option #2 doesn't have self-consistent naming.
Under it, vector-map doesn't take an index, whereas vector-fold does.
Option #3 gives the SRFI self-consistent naming that also agrees with
the R7RS, at the expense of more names and additional complexity.

John Cowan
Time alone is real
  the rest imaginary
like a quaternion       --phma