provided for compatibility
Neil W. Van Dyke 25 Apr 2005 22:10 UTC
Regarding the "provided for compatibility" aliases...
hash-table-ref === hash-table-get
hash-table-set! === hash-table-put!
hash-table-delete! === hash-table-remove!
I think aliases like this are more appropriate in a library than in a
SRFI.
Currently, the SRFI draft would require all complying Scheme
implementations to support multiple names for the same operation, which
seems a little odd ("call/cc" notwithstanding).
I'd lean towards having the SRFI specify only one name per operation,
and having the Scheme implementations and user code comply with that.
--
http://www.neilvandyke.org/