Email list hosting service & mailing list manager

why not "multiple-value-bind"?? rpw3@xxxxxx (02 Jul 1999 09:19 UTC)
why not "multiple-value-bind"?? John David Stone (02 Jul 1999 13:49 UTC)

why not "multiple-value-bind"?? rpw3@xxxxxx 02 Jul 1999 09:19 UTC

SRFI-8 proposes:

	(receive <formals> <expression> <body>)

as syntactic sugar for:

	  (lambda () <expression> )
	  (lambda <formals> <body> ))

"Receive" seems kinda non-intuitive to me (like some sort of
networking thingy). Why not call it "multiple-value-bind" as in
Common Lisp <URL:
Body/mac_multiple-value-bind.html>, which has exactly the same
specification AFAICT (except for the usual differences between
Scheme & Common Lisp lambda formals):

	(multiple-value-bind <formals> <expression> <body>)

Or if there's an adamant refusal to be the same as CL, what about
"with-values", perhaps?


p.s. I actually find "let-values" more natural than "multiple-value-bind",
but MzScheme <URL:
node18.htm> already uses "let-values" with a somewhat different syntax
than proposed above:

	(let-values ( ((variable ... ) <expression> )
		      ... )
	  <body> )

Oh, well...

Rob Warnock, 8L-855
Applied Networking
Silicon Graphics, Inc.		Phone: 650-933-1673
1600 Amphitheatre Pkwy.		FAX: 650-933-0511
Mountain View, CA  94043	PP-ASEL-IA