Re: New draft (#8) of and new "last call" for SRFI 189: Maybe and Either: optional container types Marc Nieper-WiÃkirchen 11 Jul 2020 20:06 UTC
Am Sa., 11. Juli 2020 um 21:59 Uhr schrieb Arthur A. Gleckler <firstname.lastname@example.org>: > > On Sat, Jul 11, 2020 at 12:26 PM Marc Nieper-Wißkirchen <email@example.com> wrote: > >> >> We can add this to the proposed change to SRFI 145. And make "assume = >> assert" in case of the debug feature identifier set. > > > I'm afraid that SRFI 145 has been finalized, which means that the only changes to it allowed are corrections to errors. A new SRFI that is a revised version of SRFI 145 is the alternative. Yes, indeed. I have been thinking of a replacement of SRFI 145, which will include John's idea to pull in "assert" from R6RS and my idea of linking "assume" to "assert" when a kind of debug flag is set (which should be the default). In error situations, which can, in principle be detected (like in the maybe-if case of SRFI 189), implementations are then encouraged to use "assume" (or even forced by the wording of the respective SRFI), which will give (a) the semantics John is looking for in normal runs and (b) allows a portable mode, in which the optimizer can work much more aggressively without changing the semantics.